Post

2 followers Follow
0
Avatar

"undefined method `config' for nil:NilClass" vone 3.2

Hi,

generating a VM with a NIC ending up in a failure.

What i did:

1. Install Windows 2016 Standard or Datacenter OS

2. Install vone-context-5.6.0.msi

3. Install VMware tools

4. Activating Windows

5. running sysrep with /oobe /generalize

6. removing the NIC from the vm @ vcenter

7. cloning into template

8. importing into vone

Any suggestion would be helpful, thank you !

Greetings

Oliver

 

Fri Aug 3 01:32:53 2018 [Z0][VM][I]: New state is ACTIVE
Fri Aug 3 01:32:53 2018 [Z0][VM][I]: New LCM state is PROLOG
Fri Aug 3 01:32:54 2018 [Z0][VM][I]: New LCM state is BOOT
Fri Aug 3 01:32:54 2018 [Z0][VMM][I]: Generating deployment file: /var/lib/one/vms/18/deployment.0
Fri Aug 3 01:32:54 2018 [Z0][VMM][I]: Successfully execute transfer manager driver operation: tm_context.
Fri Aug 3 01:32:54 2018 [Z0][VMM][I]: Successfully execute network driver operation: pre.
Fri Aug 3 01:34:59 2018 [Z0][VMM][I]: Command execution fail: /var/lib/one/remotes/vmm/vcenter/deploy '/var/lib/one/vms/18/deployment.0' 'cluster' 18 cluster
Fri Aug 3 01:34:59 2018 [Z0][VMM][E]: Deploy of VM 18 on vCenter cluster cluster with /var/lib/one/vms/18/deployment.0 failed due to "undefined method `config' for nil:NilClass"
Fri Aug 3 01:34:59 2018 [Z0][VMM][E]: ["/usr/lib/one/ruby/vcenter_driver/virtual_machine.rb:1733:in `calculate_add_nic_spec'", "/usr/lib/one/ruby/vcenter_driver/virtual_machine.rb:1652:in `block in device_change_nics'", "/usr/lib/one/ruby/vcenter_driver/virtual_machine.rb:1651:in `each'", "/usr/lib/one/ruby/vcenter_driver/virtual_machine.rb:1651:in `device_change_nics'", "/usr/lib/one/ruby/vcenter_driver/virtual_machine.rb:1562:in `reconfigure'", "/var/lib/one/remotes/vmm/vcenter/deploy:73:in `<main>'"]
Fri Aug 3 01:34:59 2018 [Z0][VMM][I]: ExitCode: 255
Fri Aug 3 01:34:59 2018 [Z0][VMM][I]: Failed to execute virtualization driver operation: deploy.
Fri Aug 3 01:34:59 2018 [Z0][VMM][E]: Error deploying virtual machine: Deploy of VM 18 on vCenter cluster cluster with /var/lib/one/vms/18/deployment.0 failed due to "undefined method `config' for nil:NilClass"
Fri Aug 3 01:34:59 2018 [Z0][VM][I]: New LCM state is BOOT_FAILURE

Oliver Dzombic

Please sign in to leave a comment.

1 comment